Microsoft предупредила о критической уязвимости в PowerShell 7

Пн 5 Июль 2021 13:55

Microsoft призвала пользователей как можно скорее обновить инструмент PowerShell в связи с наличием уязвимости удаленного выполнения кода в .NET Core.

PowerShell представляет собой расширяемое средство автоматизации с открытым исходным кодом, состоящее из оболочки с интерфейсом командной строки и сопутствующего языка сценариев.

Уязвимость ( CVE-2021-26701 ) затрагивает версии PowerShell 7.0 и 7.1. Проблема исправлена с выпуском версий 7.0.6 и 7.1.3 соответственно. Версия PowerShell 5.1 уязвимости не подвержена.

Как указывается в описании Microsoft, уязвимость существует в .NET 5 и .NET Core (в частности, в пакете System.Text.Encodings.Web) из-за некорректного осуществления кодировки текста. Уязвимыми являются следующие версии System.Text.Encodings.Web: 4.0.0 - 4.5.0, 4.6.0-4.7.1, 5.0.0.

Отметим, что CVE-2021-26701 была исправлена еще в начале нынешнего года в рамках февральского «вторника исправлений». Учитывая отсутствие других мер по предотвращению эксплуатации уязвимости, помимо установки обновления, пользователям настоятельно рекомендуется обновиться до последних версий PowerShell во избежание возможных атак.

Статья уведена с www.securitylab.ru.

NetLan.ru жив уже 15 лет 131 день 10 часов 53 минуты 4 секунды
СМК NetLan (Nettlesome Landloper) — некоммерческий интернет-ресурс.
Весь данный интернет-ресурс и всё созданное или размещённое на нём используется в личных целях.